게시물 261건
   
[RHEL9] root 로 ssh 접속 가능하게 하기 ; 기본적으로 RHEL9은 root가 막혀있어요.
글쓴이 : theko 날짜 : 2024-11-27 (수) 14:36 조회 : 2141
Red Hat Enterprise Linux 9에서 root 사용자로 SSH 로그인 활성화

Red Hat Enterprise Linux 9는 /etc/ssh/sshd_config 파일에서 PermitRootLogin 매개변수가 yes 로 설정되어 있어도 root 사용자로 SSH 로그인을 지원하지 않습니다. 다음과 같은 오류가 발생합니다.


[root@test01 ~]# ssh root@192.168.100.100
root@192.168.100.100 password:
Permission denied, please try again.


> 해결방안 

1) Red Hat Enterprise Linux 9를 설치하는 동안 root 암호를 설정하는 동안 "암호로 root 로그인 허용" 플래그를 사용합니다.

2) 

Red Hat Enterprise Linux 9 설치 후 PermitRootLogin 매개변수를 수동으로 설정합니다.

PermitRootLogin 매개변수의 수동 설정에 대해 설명합니다.


# echo 'PermitRootLogin yes' >> /etc/ssh/sshd_config.d/01-permitrootlogin.conf
# systemctl restart sshd.service



이름 패스워드
비밀글 (체크하면 글쓴이만 내용을 확인할 수 있습니다.)
왼쪽의 글자를 입력하세요.
   

miwit.com sir.co.kr DNS Powered by DNSEver.com DNS Powered by DNSEver.com